Nate

leandro_bk, fixed, see here. Alex, not sure, maybe it is already fixed in that same thread? If not, please create a new thread with exact steps on how to reproduce, expected and actual behavior.

Having separate windows is pretty difficult for technical reasons, since Spine uses OpenGL. Probably won't get to do it any time soon.

It's true OS X doesn't have cursor changes. I'd like to implement this and will eventually, but it is trickier than it seems and there are lots of other things to do. Maybe we could indicate the resize a different way, or by drawing our own icons near the mouse.

Jaf, I fixed opening that goblins project in 2.0.17. Note that Spine comes with a newer goblins project, look in the Spine installation directory, in the examples subdirectory.
User avatar
Nate

Nate
  • Posts: 12029

MrHoot

Just a little nitpick here, nothing too bad :p but is there an option to remove the little tweening "boing" effect you get when opening menus and windows ? :D It just distracts me a bit every time and I prefer the old style
MrHoot
  • Posts: 25

Mitch

MrHoot wrote:Just a little nitpick here, nothing too bad :p but is there an option to remove the little tweening "boing" effect you get when opening menus and windows ? :D It just distracts me a bit every time and I prefer the old style
My brother.

Spine -> Settings -> Interface Animations.
User avatar
Mitch

Mitch
  • Posts: 978

MrHoot

Mitch wrote:
MrHoot wrote:Just a little nitpick here, nothing too bad :p but is there an option to remove the little tweening "boing" effect you get when opening menus and windows ? :D It just distracts me a bit every time and I prefer the old style
My brother.

Spine -> Settings -> Interface Animations.
Thank you kindly ! I apparently unchecked the wrong thing (smooth scrolling), works as I want to now. Thanks !
MrHoot
  • Posts: 25

Jaf

Nate wrote:Jaf, I fixed opening that goblins project in 2.0.17. Note that Spine comes with a newer goblins project, look in the Spine installation directory, in the examples subdirectory.
Thank you kind Sir. Appreciate the quick updates and fixes :yes:
Mitch wrote:
MrHoot wrote:Just a little nitpick here, nothing too bad :p but is there an option to remove the little tweening "boing" effect you get when opening menus and windows ? :D It just distracts me a bit every time and I prefer the old style
My brother.

Spine -> Settings -> Interface Animations.
Awesome! While the "boing" effect is a nice touch, like MrHoot, I prefer the simple old style as well :$ Thanks for making it optional.
Jaf
  • Posts: 39

Alex

Nate wrote:leandro_bk, fixed, see here. Alex, not sure, maybe it is already fixed in that same thread? If not, please create a new thread with exact steps on how to reproduce, expected and actual behavior.
Yay! It's fixed in 2.0.17!
Thanks, Nate!
Alex
  • Posts: 18

steveR

Hello

Hello:
I own Spine and tried to download the newest version using the link in the license email. I downloaded the software and when tried to install said "can't be opened because it is from an unidentified developer. I am using a Mac, with Safari and version OS X 10.9. I have had no problem downloading earlier versions of the software.

I tried to send an email using your website form but it was returned saying " Unauthenticated email from yahoo.com is not accepted due to
domain's 550-5.7.1 DMARC policy". I also could not find and email address on your site to send directly.

Regards,
Steve
steveR
  • Posts: 10

Nate

Nothing has changed from previous versions, we have always been an "unidentified developer". See Apple's docs:
http://support.apple.com/kb/PH14369

In the future, you can contact us here:
http://esotericsoftware.com/contact
User avatar
Nate

Nate
  • Posts: 12029

hwadock

drawOder key does not work . after ver.2.0.20 :(
in unity3d
User avatar
hwadock
  • Posts: 72

Mitch

hwadock wrote:drawOder key does not work . after ver.2.0.20 :(
in unity3d
:(



Looks like it's working here ( Unity 4.5.3, Spine 2.0.20, latest runtime )

Is your runtime 100% up-to-date? PM / Skype me (Fenrisul) if you think its a Unity problem!
User avatar
Mitch

Mitch
  • Posts: 978

hwadock

Solved. thanks you Mitch!!
User avatar
hwadock
  • Posts: 72

steveR

Feature request:

Currently Spine can use background images to layout your characters. I would like to use a video background in animation mode to be able to layout animation movements from a character in the video. I believe this is called rotoscoping. I could then scrub through the video as I layout the animation using this a the template.

Thanks

PS: earlier issue with opening Spine was due the Mac Gatekeeper. I went to preferences security to enable the app.
steveR
  • Posts: 10

Søren

steveR wrote:Feature request:

Currently Spine can use background images to layout your characters. I would like to use a video background in animation mode to be able to layout animation movements from a character in the video. I believe this is called rotoscoping. I could then scrub through the video as I layout the animation using this a the template.

Thanks

PS: earlier issue with opening Spine was due the Mac Gatekeeper. I went to preferences security to enable the app.
I can almost guarantee that showing video files directly inside of Spine won't be possible, however image sequences will be possible at some point without needing to set keys for each image. I can't say when this will happen though.
User avatar
Søren

Shiu
  • Posts: 2452

Black Hive

I'm sure I'll get used to it, but be mindful changing UI on artists. I rarely goes over well :P We're a panicy bunch!
Black Hive
  • Posts: 28

kim_f

Hi, I'm on 2.0.21 (on a Mac) and I can't seem to do the wonderful trick of holding shift when creating a skeleton and having it highlight an image and create a slot correctly named with image attached. Has this changed somehow or am I missing something? Is there somewhere I can look to see what are the changes with each new version?
Cheers
kim_f
  • Posts: 4

Mitch

kim_f wrote:Hi, I'm on 2.0.21 (on a Mac) and I can't seem to do the wonderful trick of holding shift when creating a skeleton and having it highlight an image and create a slot correctly named with image attached. Has this changed somehow or am I missing something? Is there somewhere I can look to see what are the changes with each new version?
Cheers
http://esotericsoftware.com/spine-changelog
The Create tool no longer uses shift to choose an attachment to move to the new bone. Instead, after selecting the parent bone, attachments to move to the new bone can be selected by holding ctrl.
User avatar
Mitch

Mitch
  • Posts: 978

Unkle8ob

Hello.
After updating spine to 2.0.21 there seemed to appear a new feature (or probably a bug). When I work in an animation mode I still see the bones from the setup mode (I talk about bones with the IK feature applied). The double bones are visible only when the playback is on. So every bone is displayed doubled and it is not really compforatable to work like that. Is there any way to switch it off? :(
You do not have the required permissions to view the files attached to this post.
Unkle8ob
  • Posts: 1

HellaciousPuppy

Mitch wrote:
kim_f wrote:Hi, I'm on 2.0.21 (on a Mac) and I can't seem to do the wonderful trick of holding shift when creating a skeleton and having it highlight an image and create a slot correctly named with image attached. Has this changed somehow or am I missing something? Is there somewhere I can look to see what are the changes with each new version?
Cheers
http://esotericsoftware.com/spine-changelog
The Create tool no longer uses shift to choose an attachment to move to the new bone. Instead, after selecting the parent bone, attachments to move to the new bone can be selected by holding ctrl.
Hi there
I am also running 2.0.21 on Mac (10.9.5) and neither shift NOR ctrl do anything at all when creating bones. Only command does something, which is to freeze the bone and highlight the image beneath but not actually do anything to the creation of the bone. I'm guessing this is an actual bug (?)
HellaciousPuppy
  • Posts: 1

mrfreeman

HellaciousPuppy wrote:
Mitch wrote:
kim_f wrote:Hi, I'm on 2.0.21 (on a Mac) and I can't seem to do the wonderful trick of holding shift when creating a skeleton and having it highlight an image and create a slot correctly named with image attached. Has this changed somehow or am I missing something? Is there somewhere I can look to see what are the changes with each new version?
Cheers
http://esotericsoftware.com/spine-changelog
The Create tool no longer uses shift to choose an attachment to move to the new bone. Instead, after selecting the parent bone, attachments to move to the new bone can be selected by holding ctrl.
Hi there
I am also running 2.0.21 on Mac (10.9.5) and neither shift NOR ctrl do anything at all when creating bones. Only command does something, which is to freeze the bone and highlight the image beneath but not actually do anything to the creation of the bone. I'm guessing this is an actual bug (?)
same problem after update.
pls fix the bug.
cheers
mrfreeman
mrfreeman
  • Posts: 2

Nate

Sorry for the confusion on the bone Create tool changes. Please see this thread:
viewtopic.php?f=9&t=3477

Unkle8ob, sounds like you have hidden the IK constraints, so you are seeing the IK pose, the mix pose, and the FK pose. See the docs:
http://esotericsoftware.com/spine-ik-co ... ixing-FKIK

---

Unkle8ob wrote:After updating spine to 2.0.21 there seemed to appear a new feature (or probably a bug). When I work in an animation mode I still see the bones from the setup mode (I talk about bones with the IK feature applied).
Sorry, you were right and this has been fixed in 2.0.22. Thanks!
User avatar
Nate

Nate
  • Posts: 12029

kim_f

Thank you!
kim_f
  • Posts: 4

loser

nice?
loser
  • Posts: 1


Return to Editor